Preparing BD Systems for Data Migration

Contents

- Overview
- Backing Up Your Data on page 2
- Summary of the Upgrade Process on page 6
- Copying User Data Files onto an Upgraded System on page 7
- Preparing an Offline Workstation for Data Migration on page 9
- Preparing a SPA System for Data Migration on page 10

Overview

This document is for customers who are upgrading a BD cytometer system with one of the following software applications:

- BD FACSDiva™ software version 8.0.1 (from v6.0 and later)
- BD FACSCanto™ clinical software version 3.0 (from v2.2 and later)
- BD FACS™ SPA software version 5.0 (from v4.0.2 and later)

These applications run on the Microsoft® Windows® 7 (32-bit) operating system, and the workstation requires a new or completely reformatted hard
drive. This means that you have to back up all of the data from the existing hard drive.

**NOTE** It is very important that you perform this backup procedure prior to the BD Field Service Engineer (FSE) arriving to perform the upgrade installation. The BD FSE will contact you in advance to confirm that this backup has been done.

**Upgrade Considerations**

Because of a change in the beads for BD FACSDiva software v7.0 and v8.0.1, upgrading from BD FACSDiva software v6.x to v8.0.1 will cause a loss of existing baselines and application settings. All baselines, performance checks, and application settings will have to be recreated, as needed. See the *BD FACSDiva Software Reference Manual* and the *BD Cytometer Setup and Tracking Application Guide* for more details.

**Backing Up Your Data**

Customers are responsible for backing up all of their own data. Follow these steps to prepare an acquisition workstation for the upgrade to BD applications running on Windows 7.

**NOTE** Make sure that all of the data is backed up to an external device (for example, on a network drive, on a server, or on a CD/DVD), and that the external device will be available to restore the data once the upgrade is completed.

1. Start BD FACSDiva software and log in as administrator.
Export the following items to ensure that your experiments, user profiles, and custom cytometer configurations in your current system will be available for import into the Windows 7 system.

**Table 1** Items to export

<table>
<thead>
<tr>
<th>Item</th>
<th>Task</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Experiments</td>
<td>Export all experiments in the Browser to an external device.</td>
<td>See the Exporting Experiments section in the BD FACSDiva Software Reference Manual.</td>
</tr>
<tr>
<td></td>
<td>Once the experiments have been exported, we recommend deleting the experiments in the Browser.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>This needs to be performed for all user accounts.</td>
<td></td>
</tr>
<tr>
<td>User profiles</td>
<td>Export all user profiles to an external device.</td>
<td>See the Exporting User Profiles section in the BD FACSDiva Software Reference Manual.</td>
</tr>
<tr>
<td>Cytometer configurations</td>
<td>In CS&amp;T, export all the custom cytometer configurations needed after the upgrade to an external device.</td>
<td>See the Exporting a Configuration section in the BD Cytometer Setup and Tracking Application Guide.</td>
</tr>
<tr>
<td></td>
<td>We recommend printing all cytometer configurations for reference.</td>
<td></td>
</tr>
</tbody>
</table>
3. Do the tasks in the following table to reuse your templates after the upgrade.

We recommend printing the worksheets associated with each template for your reference.

Table 2 Reusing templates

<table>
<thead>
<tr>
<th>Template Type</th>
<th>Task</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analysis templates</td>
<td>Copy the folder D:\BDExport\Templates\Analysis to an external device.</td>
<td></td>
</tr>
<tr>
<td>Panel templates</td>
<td>Copy the folder D:\BDExport\Templates\Panel to an external device.</td>
<td></td>
</tr>
<tr>
<td>Plate templates</td>
<td>Copy the folder D:\BDExport\Templates\Plate to an external device.</td>
<td></td>
</tr>
<tr>
<td>Experiment templates</td>
<td>For each experiment template:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>1 Ensure that the appropriate cytometer configuration is selected.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2 Select Experiment &gt; New Experiment and select the template.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3 Export the newly created experiment to an external device.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>See the Creating an Experiment Based on a Saved Template section in the BD FACSDiva Software Reference Manual.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See the Exporting Experiments section in the BD FACSDiva Software Reference Manual.</td>
</tr>
</tbody>
</table>

4. Make a backup copy of the folder containing all of the exported experiments and move it onto the external device you are using to store all of your data.

These actions ensure that you have copies of all your critical data before starting the upgrade process.

4. Windows 7 Upgrade Instructions
5 Use the BD FACSDiva Data Manager Utility to make a backup of the BD FACSDiva database.

See the *BD FACSDiva Software Reference Manual* for instructions on using the Data Manager Utility.

6 Store any data that resides on your workstation that you want to preserve or archive to an external storage device.

One of the most important items to back up in BD FACSDiva software is the D:\BDExport folder. This folder can contain database backups, exported experiments, FCS files, templates, batch analysis reports, specimen reports, PDF reports, carousel reports, statistics exports, and worksheet elements.

Make sure you have a backup of the folders, including all subfolders, at the following locations:

**BD FACSDiva software default locations in Windows XP**

- D:\BDExport
- C:\Program Files\BD FACSDiva Software
- C:\Program Files\Common Files\BD
- C:\ABDCytometerSetupAndTracking

**BD FACSCanto clinical software default locations in Windows XP**

- C:\Program Files\BD FACSCanto Software
- D:\BDFA CSCanto\FCSFiles

**NOTE** If user-generated data is stored in customized file locations instead of the default locations, then you have to make sure to back up the data from the customized locations.
7 Identify other user-supplied software applications that will be installed after the operating system is upgraded.

Confirm that you have the needed installers for other applications you want to install, and that they are compatible with the Windows 7 32-bit operating system. If the software applications are not native 32-bit, they may not function properly.

8 If your workstation is part of a facility network, contact your local IT department to schedule a time to properly add the workstation and printer back to your facility's network following the upgrade.

See the BD Information Security Guidelines on the BD Biosciences website for more information.

Summary of the Upgrade Process

The following table shows which types of BD FACSDiva data are transferred by the BD FSE during the upgrade process.

**NOTE** Some systems will need their base cytometer configurations updated. If this is the case, you will need to re-create all custom configurations. Your previous custom configurations will still be available for viewing only. Talk to your BD sales representative to see if your system's base configuration needs updating.

**Table 3** Items transferred during the upgrade process

<table>
<thead>
<tr>
<th>Category</th>
<th>Item</th>
<th>From BD FACSDiva v6.x</th>
<th>From BD FACSDiva v7.x</th>
</tr>
</thead>
<tbody>
<tr>
<td>CS&amp;T</td>
<td>Performance tracking</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>(LJ charts)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bead lots</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>
The following types of BD FACSCanto clinical data are transferred by the BD FSE during the upgrade process:

- Preference files
- Log files
- Levey-Jennings data (.csv)
- Setup reports (.pdf)

**Copying User Data Files onto an Upgraded System**

Once the BD FSE has completed the upgrade, the next step is to copy your user-generated data files onto the new system and re-install any user-supplied applications that you backed up prior to the upgrade.

1. Change the setting in Windows 7 to show hidden files and folders.
   
   a. Select any folder and click the Organize button on the menu bar.
   
   b. Select Folder and search options to open the Folder Options dialog.
   
   c. Select the View tab and select the option to Show hidden files, folders, and drives.
   
   d. Select Apply to Folders in the Folder views section at the top of the dialog.
   
   e. Click OK to apply the setting and close the window.

2. Copy the backed-up files from your backup source to D:\Archive.

3. To use or view files from the previous system:
   
   a. Copy a file from Archive folder.
   
   b. Paste the file into the Windows 7 default folder location.

   See the Windows XP to Windows 7 Conversion Quick Reference Guide for the new Windows 7 default folder locations.
4 To use analysis, panel, and plate templates from the previous system, follow these guidelines.

- Paste templates into the correct default location.
- Ensure that the appropriate cytometer configuration and the appropriate parameters are selected prior to importing templates into BD FACSDiva software.
- Verify that the template elements are correct and save as a BD FACSDiva 8.0.1 template.

5 To convert exported experiments back to experiment templates, follow these guidelines.

- Ensure that the appropriate cytometer configuration is selected prior to importing the experiment into BD FACSDiva software.
- Verify that the template elements are correct and then save as a BD FACSDiva 8.0.1 experiment template.

6 Update the default storage location for the CS&T PDF and FCS files in the CS&T application.

The CS&T preferences were maintained during the upgrade and therefore the Windows XP default location for these files was maintained.

- Start BD FACSDiva software and log in as administrator.
- Open the CS&T application by selecting Cytometer > CST.
- Select Tools > Preferences.
- In the File Locations tab, click Reset for both the FCS files and PDF files location.
- Click OK to accept the changes.

The storage locations are now updated to the Windows 7 default locations.
7  (BD FACSCanto clinical software only) If you have optimized the settings on your cytometer prior to the upgrade process, you have to perform the optimization again once the upgrade is completed.

The .opt file from the previously optimized system will not work on the upgraded system. See your cytometer manual for instructions on optimizing settings.

8  Re-install any user-supplied applications that you backed up prior to the upgrade.

9  As needed, import any exported experiments back into the upgraded system.

   a  Select File > Import > Experiments.

   b  Locate the experiment to be imported in the dialog that opens.

   c  Select the folder containing the required experiments and click Import.

See the BD FACSDiva Software Reference Manual for more details on importing experiments.

Preparing an Offline Workstation for Data Migration

If you have an offline analysis workstation running BD FACSDiva software that you want to upgrade to version 8.0.1, follow these steps. These instructions also apply if you are upgrading BD FACSCanto clinical software to version 3.0. Note that you must supply the Windows 7 (32-bit) operating system.

NOTE  If the D drive does not exist on an offline workstation, the BD file paths revert to the C drive.

1  Verify that the workstation meets the minimum requirements for BD FACSDiva software v8.0.1.

   Analysis-only workstations must be equipped with an Intel® i5-650 processor or higher with at least 4 GB of RAM and the Windows 7 32-bit operating system (US English only). For optimal performance and full analysis capability, we recommend that you purchase a workstation that
has been validated by BD Biosciences. Contact your sales representative for more information.

2 Use the BD FACSDiva Data Manager Utility to make a backup of the BD FACSDiva database.

See the *BD FACSDiva Software Reference Manual* for instructions on using the Data Manager Utility.

3 Perform the backup procedure described in Backing Up Your Data on page 2.

4 Install the Windows 7 (32-bit) operating system.

5 After the new operating system is installed, install BD FACSDiva software v8.0.1.

See the *BD FACSDiva Software Installation Guide* for instructions.

If you are installing BD FACSCanto clinical software, see the *BD FACSCanto Clinical Software Reference Manual*.

**NOTE** The BD FACSDiva application must be installed into a location where a person with a standard user account will have read/write access.

6 (Optional) To maintain the same cytometer configurations as the previous system, transfer the cytometer configuration files.

See the topic on transferring a configuration file in the *BD Cytometer Setup and Tracking Application Guide*.

7 Restore any other data files or applications that you backed up before starting the upgrade process, following the steps in Copying User Data Files onto an Upgraded System on page 7.

### Preparing a SPA System for Data Migration

Follow these steps to prepare for an upgrade to SPA software v5.0 running on Windows 7.
1. Store any data that resides on your workstation that you want to preserve to an external storage device.

2. Verify that you have backed up the following folder, including all sub-folders:

   C:\Program Files\BD FACS SPA Software

3. Verify that you have the worktable database file (BD–HwWktb.mdb) available so that the BD FSE can complete the upgrade process. The default location for the file is C:\Program Files\BD FACS SPA Software\Data files.

4. Review the information in the following list that shows which types of data are transferred by the BD FSE during the upgrade process.
   - Data files (panels and reagent rack)
   - RandMove.txt
   - Setup.dat
   - Setting.txt

5. Once the BD FSE has completed the upgrade, copy your backed-up user-generated data files onto the new system.

6. Re-install any user-supplied applications that you backed up prior to the upgrade.